본문으로 바로가기

WAN - PPP (Point to Point Protocol) & MLPPP, PPPoE

category 네트워크/All about Network 2020. 3. 4. 16:20
반응형
PPP (Point to Point Protocol)

PPP (Point to Point Protocol)는 HDLC와 마찬가지로 포인트 투 포인트시리얼 인터페이스 환경에서 사용되는 장거리 통신망용 링크 레이어 프로토콜이다. PPP는 다시 LCP(Link Control Protocol)NCP(Network Control Protocol)로 구성된다.


LCP는 PPP로 동작하는 두 장비 간의 링크셋업하기 위하여 사용되며, 다음과 같은 기능을 제공한다.


ⅰ. 회선 품질 모니터링(LQM(Link Quality Monitoring)) : PPP는 프레임을 받는 수신측이 에러 없이 제대로 수신한 패킷 및 바이트 수상대에게 알려줄 수 있다. 이를 이용하여 송신측이 자신이 보낸 수상대방이 제대로 받았다고 알려준 수비교하여 패킷 손실률을 계산한다. 이후, 사전에 설정된 값 이상의 회선 에러가 발생하면 해당 링크를 다운시켜 라우팅 프로토콜로 하여금 더 좋은 경로를 선택할 수 있게 한다.

ⅱ. 링크 루프 탐지 : PPP의 링크를 구성하는 DSU/CSU, 또는 장거리 통신망 등에서 상대가 보내는 프레임을 목적지로 전송하지 않고 거꾸로 상대에게 전송하는 루프(loop) 테스트가 있는데, 주로 회선 또는 장비가 제대로 동작하는지 확인하기 위해서 루프 테스트를 실행한다. 그 때 테스트 후 정상적으로 복귀되지 않고 그대로 두거나 장애가 발생하는 경우가 있는데 이러한 상태를 PPP가 찾아낼 수 있다. 이럴 때 PPP는 LCP 메세지를 전송할 때 장비별로 고유한 매직 넘버(magic number)를 포함시켜서 상대방에게 수신한 메세지에 자신이 보낸 매직 넘버가 있다면 도중에 루프가 걸려서 되돌아왔다는 뜻이므로 이런 방식을 통해 루프를 탐지할 수 있다.

ⅲ. MultiLink : 이더넷 스위치에서 사용하는 이더채널과 같이 여러개의 회선하나의 회선처럼 사용할 수 있다.

ⅳ. 인증 : PPP는 다른 Layer 2 프로토콜이 가지지 못한 상대방을 인증할 수 있는 기능을 가지고 있는데, PAPCHAP등이 있다. PAP(Password Authentication Protocol)는 이용자명과 암호를 평문으로 전송하고, CHAP(Challenge Handshake Authentication Protocol)는 실제 암호를 전송하지 않고 암호를 이용해서 만든 코드값MD5로 전송시킨다. 고로 PAP보다는 보안성을 중시한 CHAP을 더 많이 사용한다. 


PPP의 LCP 옵션들은 모두 명시적으로 설정해주어야 동작하며, 두 장비가 패킷을 전송하여 링크를 설정하고, 링크가 설정되면 필요 시 인증을 수행한다. 이후 NCP가 동작하여 하나 이상의 네트워크 계층 프로토콜을 동작시킨다.


장비 기본 설정 & 기본 설정 파일
Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#enable secret cisco
R1(config)#no ip domain-lookup

R1(config)#line console 0
R1(config-li)#logging sync
R1(config-li)#exec-time 0
R1(config-li)#exit

ISP(config)#line vty 0 4
ISP(config-li)#password cisco
ISP(config-li)#exit


기본적인 PPP 설정

PPP는 다른 Layer 2 프로토콜에 없는 인증 기능으로 가장 많이 사용되고있는 프로토콜 중 하나이다. 설정이 간단하며 표준 프로토콜이기 때문에 전용선으로 라우터를 연결할 때 많이 사용한다. xDSL, 케이블 네트워크 등에서 링크 계층 프로토콜로 이더넷이나 ATM을 사용하는데, 이 때 사용자를 인증하기 위하여 PPPoE(PPP over Ethernet), PPPoA(PPP over ATM) 등의 형태로 PPP를 이더넷이나 ATM에 같이 결합하여 사용한다. R2와 R3에 각각 PPP를 설정한다.

R2(config)#int s1/1
R2(config-if)#encapsulation ppp

R3(config-if)#int s1/1
R3(config-if)#encapsulation ppp

설정 후 잠시 인터페이스가 다운되었다가 살아나는 것을 확인할 수 있다. R2의 인터페이스를 확인해보면 인캡슐레이션PPP로 변경된 것을 확인할 수 있다.

R2#sh int s1/1
Serial1/1 is up, line protocol is up 
  Hardware is M4T
  Internet address is 10.10.23.2/24
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP, CDPCP, crc 16, loopback not set
....

여기에 IGP인 EIGRP 라우팅 프로토콜을 와일드카드 마스크를 사용하지 않고 설정하면 넥스트 홉 IP 주소를 호스트 루트(Host route), 즉 32비트 마스크를 가진 네트워크로 라우팅 테이블에 인스톨 시킨다.

R1(config)#router eigrp 1
R1(config-router)#network 10.0.0.0

R2(config)#router eigrp 1
R2(config-router)#network 10.0.0.0

R3(config)#router eigrp 1
R3(config-router)#network 10.0.0.0

R4(config)#router eigrp 1
R4(config-router)#network 10.0.0.0

R2의 라우팅 테이블을 확인해보면 넥스트 홉 주소10.10.23.3/32호스트 루트인 32비트 마스크를 가진 네트워크로 인스톨 되어있는 것을 확인할 수 있다.

R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        10.10.12.0/24 is directly connected, Ethernet0/0
L        10.10.12.2/32 is directly connected, Ethernet0/0
C        10.10.23.0/24 is directly connected, Serial1/1
L        10.10.23.2/32 is directly connected, Serial1/1
C        10.10.23.3/32 is directly connected, Serial1/1
D        10.10.34.0/24 [90/2195456] via 10.10.23.3, 00:00:20, Serial1/1

혹 이 호스트 루트를 제거하기 위해서는 인터페이스 설정에서 no peer neighbor-route 명령어를 사용하여 제거할 수 있다.

R2(config)#int s1/1
R2(config-if)#no peer neighbor-route
R2(config-if)#exit
R2(config)#exit
R2#clear ip route *

사용 후 clear ip route * 명령어를 이용하여 라우팅 테이블정리한 후 확인해보면 10.10.23.3/32 호스트 루트가 제거된 것을 확인할 수 있다.

R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.10.12.0/24 is directly connected, Ethernet0/0
L        10.10.12.2/32 is directly connected, Ethernet0/0
C        10.10.23.0/24 is directly connected, Serial1/1
L        10.10.23.2/32 is directly connected, Serial1/1
D        10.10.34.0/24 [90/2195456] via 10.10.23.3, 00:01:21, Serial1/1


PPP 인증 (Authentication)

위에서도 언급했듯이 PPP는 이더넷, HDLC 등 다른 Layer 2 프로토콜이 가지지 못한 인증(Authentication) 기능을 가지고 있다. 장비 기본 설정에서 설정한 hostname을 PPP 인증에서 사용할 수 있다.

R2(config)#username R3 password NETSTUDY 
R2(config)#interface s1/1
R2(config-if)#ppp authentication chap

R3(config)#username R2 password NETSTUDY
R3(config)#interface s1/1
R3(config-if)#ppp authentication chap

ⅰ. username R3 password NETSTUDY : 인증에 사용할 상대방의 Hostname비밀번호를 지정한다.

ⅱ. ppp authentication chap : PPP 인증 방식을 지정한다. 인증 방식은 아래와 같이 여러 종류가 있으며, PPP 인증을 이용할 라우터에서 모두 설정을 해줘야 상호 인증을 하게 된다.

R2(config-if)#ppp authentication ?
  chap        Challenge Handshake Authentication Protocol (CHAP)
  eap         Extensible Authentication Protocol (EAP)
  ms-chap     Microsoft Challenge Handshake Authentication Protocol (MS-CHAP)
  ms-chap-v2  Microsoft CHAP Version 2 (MS-CHAP-V2)
  pap         Password Authentication Protocol (PAP)

debug 명령어를 통하여 PPP의 인증을 디버깅해보면 상호 인증을 요구하고(CHALLENGE), 응답을 하고(RESPONSE), 인증에 성공(SUCCESS) 후 죽었던 링크가 살아나는 것을 확인할 수 있다.

*Mar  4 01:31:26.651: Se1/1 PPP: Using default call direction
*Mar  4 01:31:26.651: Se1/1 PPP: Treating connection as a dedicated line
*Mar  4 01:31:26.651: Se1/1 PPP: Session handle[E700006C] Session id[107]
*Mar  4 01:31:26.681: Se1/1 CHAP: O CHALLENGE id 1 len 23 from "R2"              // R2의 상호 인증 요구 전송
*Mar  4 01:31:26.688: Se1/1 CHAP: I CHALLENGE id 1 len 23 from "R3"              // R3의 상호 인증 요구 전송
*Mar  4 01:31:26.688: Se1/1 PPP: Sent CHAP SENDAUTH Request
*Mar  4 01:31:26.688: Se1/1 PPP: Received SENDAUTH Response PASS
*Mar  4 01:31:26.688: Se1/1 CHAP: Using hostname from configured hostname        // 설정 된 hostname 사용
*Mar  4 01:31:26.688: Se1/1 CHAP: Using password from AAA                        // 설정 된 Password 사용
*Mar  4 01:31:26.688: Se1/1 CHAP: O RESPONSE id 1 len 23 from "R2"               // R2의 응답 전송
*Mar  4 01:31:26.690: Se1/1 CHAP: I RESPONSE id 1 len 23 from "R3"               // R3의 응답 수신
*Mar  4 01:31:26.690: Se1/1 PPP: Sent CHAP LOGIN Request
*Mar  4 01:31:26.690: Se1/1 PPP: Received LOGIN Response PASS
*Mar  4 01:31:26.696: Se1/1 CHAP: O SUCCESS id 1 len 4                           // R2의 성공 전송
*Mar  4 01:31:26.699: Se1/1 CHAP: I SUCCESS id 1 len 4                           // R3의 성공 수신
*Mar  4 01:31:26.699: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up


멀티링크 PPP (MLPPP, MultiLink PPP)

멀티링크 PPP (MLPPP, MultiLink PPP)는 두 개 이상의 PPP 회선을 하나의 회선처럼 동작시키는 것을 말한다. MLPPP를 사용하면 트래픽 전송 시 정밀한 부하부산이 이루어진다. MLPPP 설정은 위의 PPP Authentication이 적용되어 있어야 링크가 살아난다.

R2(config)#interface multilink 23
R2(config-if)#encapsulation ppp
R2(config-if)#ppp multilink
R2(config-if)#ppp multilink group 23
R2(config-if)#ip address 10.10.23.2 255.255.255.0
R2(config-if)#exit
R2(config)#
R2(config)#int s1/1
R2(config-if)#encapsulation ppp
R2(config-if)#ppp multilink 
R2(config-if)#ppp multilink group 23
R2(config-if)#ppp authentication chap
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#
R2(config)#int s1/2
R2(config-if)#encapsulation ppp
R2(config-if)#ppp multilink
R2(config-if)#ppp multilink group 23
R2(config-if)#ppp authentication chap
R2(config-if)#no shut
R2(config-if)#exit

MLPPP의 인터페이스 번호1~65,535 사이의 적당한 번호를 지정하여 MLPPP 인터페이스 링크를 만들 수 있다. 이 번호는 MLPPP 인터페이스와 시리얼 인터페이스의 MultiLink 그룹 번호랑 같아야한다. ppp multilink 명령어를 통하여 MLPPP를 동작시키고 그룹 번호를 지정한다. 또한 IP 주소는 MLPPP 인터페이스에서만 설정할 수 있고 PPP 인증은 시리얼 인터페이스에서 지정할 수 있다.

R3(config)#interface multilink 23
R3(config-if)#encapsulation ppp
R3(config-if)#ppp multilink
R3(config-if)#ppp multilink group 23
R3(config-if)#ip address 10.10.23.3 255.255.255.0
R3(config-if)#exit
R3(config)#
R3(config)#int s1/1
R3(config-if)#encapsulation ppp
R3(config-if)#ppp multilink 
R3(config-if)#ppp multilink group 23
R3(config-if)#ppp authentication chap
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#
R3(config)#int s1/2
R3(config-if)#encapsulation ppp
R3(config-if)#ppp multilink
R3(config-if)#ppp multilink group 23c
R3(config-if)#ppp authentication chap
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#

R3도 마찬가지로 설정한 뒤 show ppp multilink 명령어를 통하여 MLPPP의 동작 상태를 확인할 수 있다.

R2#show ppp multilink

Multilink23
  Bundle name: R3
  Remote Username: R3
  Remote Endpoint Discriminator: [1] R3
  Local Username: R2
  Local Endpoint Discriminator: [1] R2
  Bundle up for 00:00:17, total bandwidth 3088, load 1/255
  Receive buffer limit 24000 bytes, frag timeout 1000 ms
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 0 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x7 received sequence, 0x7 sent sequence
  Member links: 2 active, 0 inactive (max 255, min not set)
    Se1/1, since 00:00:17
    Se1/2, since 00:00:16
No inactive multilink interfaces

인터페이스 브리핑 명령어를 통하여 생성한 MLPPP 인터페이스를 확인할 수 있으며, EIGRP 네이버라우팅 테이블에서도 MLPPP 인터페이스를 확인할 수 있다.

R2#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                10.10.12.2      YES manual up                    up      
Ethernet0/1                unassigned      YES unset  administratively down down    
Ethernet0/2                unassigned      YES unset  administratively down down    
Ethernet0/3                unassigned      YES unset  administratively down down    
Serial1/0                  unassigned      YES unset  up                    down    
Serial1/1                  unassigned      YES unset  up                    up      
Serial1/2                  unassigned      YES unset  up                    up      
Serial1/3                  unassigned      YES unset  administratively down down    
Multilink23                10.10.23.2      YES manual up                    up      
R2#sh ip eigrp neigh
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   10.10.23.3              Mu23                     13 00:12:01   11   100  0  7
0   10.10.12.1              Et0/0                    11 00:18:04    9   100  0  4
R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        10.10.12.0/24 is directly connected, Ethernet0/0
L        10.10.12.2/32 is directly connected, Ethernet0/0
C        10.10.23.0/24 is directly connected, Multilink23
L        10.10.23.2/32 is directly connected, Multilink23
C        10.10.23.3/32 is directly connected, Multilink23
D        10.10.34.0/24 [90/1366528] via 10.10.23.3, 00:12:04, Multilink23


PPPoE (PPP over Ethernet)

PPPoE (PPP over Ethernet)는 사용자 인증을 위하여 이더넷 인터페이스에 PPP를 동작시키는 것을 말한다. 아래 토플로지와 같이 ISP와 고객사 라우터[각주:3] 사이에 PPPoE를 설정함으로써 이더넷으로 인터넷에 연결될 때 인증 절차를 거치고 IP 주소를 받아가도록 설정한다.

ISP(config)#ip local pool ISP 10.10.10.1 10.10.10.10             // 고객 장비 할당할 IP 주소범위 풀 이름, 범위 지정
ISP(config)#bba-group pppoe ISP_Group                            // PPPoE 그룹 이름 지정

*Mar  4 03:04:36.804: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
*Mar  4 03:04:36.804: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

ISP(config-bba-group)#virtual-template 1                         // PPPoE 그룹에서 사용할 가상 인터페이스 번호 지정
ISP(config-bba-group)#exit

ISP(config)#interface virtual-template 1                         // 가상 인터페이스 설정 진입
ISP(config-if)#ip address 10.10.10.254 255.255.255.0             // 가상 인터페이스 IP 주소 설정
ISP(config-if)#peer default ip address pool ISP                  // 고객 장비 할당할 IP 주소범위 풀 이름 지정
ISP(config-if)#ppp authentication chap callin                    // 고객이 Call-in (접속 시도)시 CHAP 인증
ISP(config-if)#exit

ISP(config)#int e0/0                                             // 고객 장비와 연결되는 물리적 인터페이스 설정 진입
ISP(config-if)#pppoe enable group ISP_Group                      // PPPoE 그룹 이름 지정
ISP(config-if)#no shut    
ISP(config-if)#exit

*Mar  4 03:06:34.744: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Mar  4 03:06:35.747: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up

ISP(config)#username Customer1 password NETSTUDY1                // 인증 위한 고객 ID, PW 생성
ISP(config)#username Customer2 password NETSTUDY2
ISP(config)#username Customer3 password NETSTUDY3

ISP(config)#int lo 0                                             // 통신 테스트 위한 Loopback 설정 생성
ISP(config-if)#ip add 4.4.4.4 255.255.255.0
ISP(config-if)#

ISP의 설정이 끝나면 고객사 장비에 아래와 같이 PPPoE를 설정해준다.

Customer1(config)#interface dialer 1                      // 가상 인터페이스 생성 (0 ~ 255 사이)
Customer1(config-if)#ip address negotiated                // IP 주소를 PPP를 통하여 ISP로부터 받아오도록 지정 (협상)
Customer1(config-if)#mtu 1492                             // PPPoE 패킷 8Byte 지정 (일반적인 MTU 크기 1500Byte)
Customer1(config-if)#encapsulation ppp                    // PPP 설정
Customer1(config-if)#ppp chap hostname Customer1          // CHAP 인증 요청시 사용할 Hostname 지정
Customer1(config-if)#ppp chap password NETSTUDY1          // CHAP 인증 요청시 사용할 Password 지정
Customer1(config-if)#dialer pool 1                        // 할당할 Pool 지정, PPPoE 동작 명령어
Customer1(config-if)#exit 

Customer1(config)#int e0/0                                // ISP와 연결되는 물리적 인터페이스 설정 진입
Customer1(config-if)#pppoe-client dial-pool-number 1      // Pool 번호 지정, 지정시 자동으로 pppoe enable 활성화
Customer1(config-if)#pppoe enable
*Mar  4 03:10:08.406: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
*Mar  4 03:10:08.407: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
Customer1(config-if)#no shut
Customer1(config-if)#exit

*Mar  4 03:10:11.662: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Mar  4 03:10:12.669: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
*Mar  4 03:10:19.550: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Mar  4 03:10:19.554: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Mar  4 03:10:19.607: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up

Customer1(config)#ip route 0.0.0.0 0.0.0.0 dialer 1       // 위에서 생성한 가상 인터페이스로 디폴트 루트 설정

나머지 고객사 장비도 똑같이 설정 후 인터페이스를 브리핑으로 확인해보면 설정한 가상 인터페이스인 Dialer1이 설정되어있는 것을 확인할 수 있다.

Customer1#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                unassigned      YES unset  up                    up      
Ethernet0/1                unassigned      YES unset  administratively down down    
Ethernet0/2                unassigned      YES unset  administratively down down    
Ethernet0/3                unassigned      YES unset  administratively down down    
Dialer1                    10.10.10.1      YES IPCP   up                    up      
Virtual-Access1            unassigned      YES unset  up                    up      
Virtual-Access2            unassigned      YES unset  up                    up    

인터페이스 명령어를 사용해 가상 인터페이스인 Dialer1을 확인해보면 PPPoE가 동작하는 인터페이스에 대해서 상세한 정보를 확인할 수 있다.

Customer1#show interfaces dialer 1
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address is 10.10.10.1/32
  MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi2
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:04:10
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     9 packets input, 566 bytes
     37 packets output, 1058 bytes
Bound to:
Virtual-Access2 is up, line protocol is up 
  Hardware is Virtual Access interface
  MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Stopped: CDPCP
  Open: IPCP
  PPPoE vaccess, cloned from Dialer1
  Vaccess status 0x44, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Interface is bound to Di1 (Encapsulation PPP)
  Last input 00:00:09, output never, output hang never
  Last clearing of "show interface" counters 00:02:49
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     45 packets input, 1075 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     44 packets output, 1169 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

PPPoE 세션 확인 명령어를 이용하여 ISP의 MAC 주소 등을 확인할 수 있다.

Customer1#show pppoe session 
     1 client session 

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
           SID  LocMAC                                      VA-st      Type
    N/A      1  aabb.cc00.4000  Et0/0                   Di1 Vi2        UP      
                aabb.cc00.1000                              UP              


  1. ROUTER, SWITCH는 각각 L3 IOU, L2 IOU 이미지를 사용하였다. [본문으로]
  2. 복사하여 터미널 프로그램에 붙여넣기 하면 편하게 사용할 수 있다. [본문으로]
  3. 라우터, 또는 PC 등의 종단 장치 [본문으로]
반응형

댓글을 달아 주세요