en
conf t
enable secret cisco
no ip domain-lookup
line con 0
logging sync
exec-time 0
line vty 0 4
password cisco
exit
hostname
구성 목표
Hierarchical 3 Layer 모델 구성, 각 Layer 확인
네트워크 개수에 맞는 IP 할당
통신을 위해서 라우터에 EIGRP Routing Protocol 할당
모든 장비의 PING을 통한 연결 확인
Hierarchical 3 Layer 모델 구성, 각 Layer 확인
네트워크 설계 시 Hierarchical 3 Layer 모델을 활용하여 네트워크를 구축한다. Core Layer(코어 계층), Distribution Layer(디스트리뷰션 계층), Access Layer(엑세스 계층)으로 분류할 수 있으며 각 계층마다 Switch, Router, Switch 장비를 구성한다. 하나의 회사 네트워크를 구성할 때 각 조직을 구성하는 최소 1대의 엑세스 계층, 그리고 조직을 연결하는 최소 1대의 디스트리뷰션 계층, 그 디스트리뷰션 계층을 연결하는 최소 1대 이상의 코어 계층이 필요하다.
위와 같은 Topology에는 5개의 Switch 장비가 있는 Access Layer, 3개의 Router 장비가 있는 Distribution Layer, 1개의 Switch 장비가 있는 Core Layer로 나눌 수 있다.
네트워크 개수에 맞는 IP 할당
네트워크는 Router 장비에 의해서 분할되므로 총 6개의 Network로 나뉘어진다. 서브넷 마스크를 255.255.255.0[각주:3]으로 뒀을 때 20.1.1.0/24 ~ 20.1.6.0/24로 나누어 볼 수 있다. 또한 20.1.2.0/24 ~ 20.1.6.0/24 네트워크의 종단 장치인 PC의 Gateway는 각 네트워크의 첫 번째 IP를 할당한다.
ISP#conf t
Enter configuration commands, one per line. End with CNTL/Z.
ISP(config)#int e0/0
ISP(config-if)#ip add 20.1.1.1 255.255.255.0
ISP(config-if)#no sh
ISP(config-if)#exit
ISP(config)#
ISP#sh ip int br
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 20.1.1.1 YES manual up up
Ethernet0/1 unassigned YES unset administratively down down
Ethernet0/2 unassigned YES unset administratively down down
Ethernet0/3 unassigned YES unset administratively down down
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int e0/0
R1(config-if)#ip add 20.1.1.2 255.255.255.0
R1(config-if)#no sh
R1(config-if)#int e0/1
R1(config-if)#ip add 20.1.2.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#int e0/2
R1(config-if)#ip add 20.1.3.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#exit
R1(config)#
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int e0/0
R2(config-if)#ip add 20.1.1.3 255.255.255.0
R2(config-if)#no sh
R2(config-if)#int e0/1
R2(config-if)#ip add 20.1.4.1 255.255.255.0
R2(config-if)#no sh
R2(config-if)#int e0/2
R2(config-if)#ip add 20.1.5.1 255.255.255.0
R2(config-if)#no sh
R2(config-if)#exit
R2(config)#
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#int e0/0
R3(config-if)#ip add 20.1.1.4 255.255.255.0
R3(config-if)#no sh
R3(config-if)#int e0/1
R3(config-if)#ip add 20.1.6.1 255.255.255.0
R3(config-if)#no sh
R3(config-if)#exit
R3(config)#
R1#sh ip int br
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 20.1.1.2 YES manual up up
Ethernet0/1 20.1.2.1 YES manual up up
Ethernet0/2 20.1.3.1 YES manual up up
Ethernet0/3 unassigned YES unset administratively down down
R2#sh ip int br
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 20.1.1.3 YES manual up up
Ethernet0/1 20.1.4.1 YES manual up up
Ethernet0/2 20.1.5.1 YES manual up up
Ethernet0/3 unassigned YES unset administratively down down
R3#sh ip int br
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 20.1.1.4 YES manual up up
Ethernet0/1 20.1.6.1 YES manual up up
Ethernet0/2 unassigned YES unset administratively down down
Ethernet0/3 unassigned YES unset administratively down down
VPCS> ip 20.1.2.2 255.255.255.0 gateway 20.1.2.1
Checking for duplicate address...
PC1 : 20.1.2.2 255.255.255.0 gateway 20.1.2.1
VPCS> ip 20.1.2.3 255.255.255.0 gateway 20.1.2.1
Checking for duplicate address...
PC1 : 20.1.2.3 255.255.255.0 gateway 20.1.2.1
VPCS> ip 20.1.3.2 255.255.255.0 gateway 20.1.3.1
Checking for duplicate address...
PC1 : 20.1.3.2 255.255.255.0 gateway 20.1.3.1
VPCS> ip 20.1.3.3 255.255.255.0 gateway 20.1.3.1
Checking for duplicate address...
PC1 : 20.1.3.3 255.255.255.0 gateway 20.1.3.1
VPCS> ip 20.1.4.2 255.255.255.0 gateway 20.1.4.1
Checking for duplicate address...
PC1 : 20.1.4.2 255.255.255.0 gateway 20.1.4.1
VPCS> ip 20.1.4.3 255.255.255.0 gateway 20.1.4.1
Checking for duplicate address...
PC1 : 20.1.4.3 255.255.255.0 gateway 20.1.4.1
VPCS> ip 20.1.5.2 255.255.255.0 gateway 20.1.5.1
Checking for duplicate address...
PC1 : 20.1.5.2 255.255.255.0 gateway 20.1.5.1
VPCS> ip 20.1.5.3 255.255.255.0 gateway 20.1.5.1
Checking for duplicate address...
PC1 : 20.1.5.3 255.255.255.0 gateway 20.1.5.1
VPCS> ip 20.1.6.2 255.255.255.0 gateway 20.1.6.1
Checking for duplicate address...
PC1 : 20.1.6.2 255.255.255.0 gateway 20.1.2.1
통신을 위해서 라우터에 EIGRP 100 할당
각 네트워크와의 통신을 위해서 Router에 Distance Vector Routing Protocol 중 하나인 EIGRP Routing Protocol을 할당한다. 조직을 구분하는 AS(Autonomus System) Number는 100을 할당해준다.
ISP#conf t
Enter configuration commands, one per line. End with CNTL/Z.
ISP(config)#router eigrp 100
ISP(config-router)#network 20.0.0.0
ISP(config-router)#exit
ISP(config)#
ISP#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
20.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C 20.1.1.0/24 is directly connected, Ethernet0/0
L 20.1.1.1/32 is directly connected, Ethernet0/0
D 20.1.2.0/24 [90/307200] via 20.1.1.2, 00:11:28, Ethernet0/0
D 20.1.3.0/24 [90/307200] via 20.1.1.2, 00:11:28, Ethernet0/0
D 20.1.4.0/24 [90/307200] via 20.1.1.3, 00:11:12, Ethernet0/0
D 20.1.5.0/24 [90/307200] via 20.1.1.3, 00:11:12, Ethernet0/0
D 20.1.6.0/24 [90/307200] via 20.1.1.4, 00:09:05, Ethernet0/0
ISP#
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router eigrp 100
R1(config-router)#network 20.0.0.0
R1(config-router)#exit
R1(config)#
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router eigrp 100
R2(config-router)#network 20.0.0.0
R2(config-router)#exit
R2(config)#
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#router eigrp 100
R3(config-router)#network 20.0.0.0
R3(config-router)#exit
R3(config)#
R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
20.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
C 20.1.1.0/24 is directly connected, Ethernet0/0
L 20.1.1.2/32 is directly connected, Ethernet0/0
C 20.1.2.0/24 is directly connected, Ethernet0/1
L 20.1.2.1/32 is directly connected, Ethernet0/1
C 20.1.3.0/24 is directly connected, Ethernet0/2
L 20.1.3.1/32 is directly connected, Ethernet0/2
D 20.1.4.0/24 [90/307200] via 20.1.1.3, 00:13:16, Ethernet0/0
D 20.1.5.0/24 [90/307200] via 20.1.1.3, 00:13:16, Ethernet0/0
D 20.1.6.0/24 [90/307200] via 20.1.1.4, 00:11:09, Ethernet0/0
R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
20.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
C 20.1.1.0/24 is directly connected, Ethernet0/0
L 20.1.1.3/32 is directly connected, Ethernet0/0
D 20.1.2.0/24 [90/307200] via 20.1.1.2, 00:13:20, Ethernet0/0
D 20.1.3.0/24 [90/307200] via 20.1.1.2, 00:13:20, Ethernet0/0
C 20.1.4.0/24 is directly connected, Ethernet0/1
L 20.1.4.1/32 is directly connected, Ethernet0/1
C 20.1.5.0/24 is directly connected, Ethernet0/2
L 20.1.5.1/32 is directly connected, Ethernet0/2
D 20.1.6.0/24 [90/307200] via 20.1.1.4, 00:11:12, Ethernet0/0
R3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
20.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C 20.1.1.0/24 is directly connected, Ethernet0/0
L 20.1.1.4/32 is directly connected, Ethernet0/0
D 20.1.2.0/24 [90/307200] via 20.1.1.2, 00:12:11, Ethernet0/0
D 20.1.3.0/24 [90/307200] via 20.1.1.2, 00:12:11, Ethernet0/0
D 20.1.4.0/24 [90/307200] via 20.1.1.3, 00:12:14, Ethernet0/0
D 20.1.5.0/24 [90/307200] via 20.1.1.3, 00:12:14, Ethernet0/0
C 20.1.6.0/24 is directly connected, Ethernet0/1
L 20.1.6.1/32 is directly connected, Ethernet0/1
모든 장비의 PING을 통한 연결 확인
각 네트워크의 종단 장비인 PC를 이용하여 Ping을 통한 네트워크 연결 상태를 확인할 수 있다. VPC11 -> ISP, VPC11 -> VPC13, VPC11 -> VPC15, VPC11 -> VPC17, VPC11 -> VPC19를 통하여 각각의 네트워크의 연결을 확인한다.
VPCS> ping 20.1.1.1
84 bytes from 20.1.1.1 icmp_seq=1 ttl=254 time=0.823 ms
84 bytes from 20.1.1.1 icmp_seq=2 ttl=254 time=1.030 ms
84 bytes from 20.1.1.1 icmp_seq=3 ttl=254 time=1.204 ms
84 bytes from 20.1.1.1 icmp_seq=4 ttl=254 time=1.042 ms
84 bytes from 20.1.1.1 icmp_seq=5 ttl=254 time=0.939 ms
VPCS> ping 20.1.3.2
84 bytes from 20.1.3.2 icmp_seq=1 ttl=63 time=1.416 ms
84 bytes from 20.1.3.2 icmp_seq=2 ttl=63 time=0.916 ms
84 bytes from 20.1.3.2 icmp_seq=3 ttl=63 time=1.014 ms
84 bytes from 20.1.3.2 icmp_seq=4 ttl=63 time=1.008 ms
84 bytes from 20.1.3.2 icmp_seq=5 ttl=63 time=1.168 ms
VPCS> ping 20.1.4.2
84 bytes from 20.1.4.2 icmp_seq=1 ttl=62 time=1.943 ms
84 bytes from 20.1.4.2 icmp_seq=2 ttl=62 time=1.388 ms
84 bytes from 20.1.4.2 icmp_seq=3 ttl=62 time=1.574 ms
84 bytes from 20.1.4.2 icmp_seq=4 ttl=62 time=1.612 ms
84 bytes from 20.1.4.2 icmp_seq=5 ttl=62 time=1.365 ms
VPCS> ping 20.1.5.2
84 bytes from 20.1.5.2 icmp_seq=1 ttl=62 time=2.079 ms
84 bytes from 20.1.5.2 icmp_seq=2 ttl=62 time=1.942 ms
84 bytes from 20.1.5.2 icmp_seq=3 ttl=62 time=1.359 ms
84 bytes from 20.1.5.2 icmp_seq=4 ttl=62 time=1.493 ms
84 bytes from 20.1.5.2 icmp_seq=5 ttl=62 time=1.541 ms
VPCS> ping 20.1.6.2
84 bytes from 20.1.6.2 icmp_seq=1 ttl=62 time=3.494 ms
84 bytes from 20.1.6.2 icmp_seq=2 ttl=62 time=2.403 ms
84 bytes from 20.1.6.2 icmp_seq=3 ttl=62 time=1.510 ms
84 bytes from 20.1.6.2 icmp_seq=4 ttl=62 time=1.653 ms
84 bytes from 20.1.6.2 icmp_seq=5 ttl=62 time=1.282 ms