본문으로 바로가기

VLAN(Virtual LAN) (3) +α - Inter-VLAN 추가 실습

category 소개/+α 2018. 10. 30. 00:08
반응형
  • 참고 Topology

기존의 VLAN(Virtual LAN) (3) - Trunking (802.1Q, ISL), DTP, VTP 게시글에서는 VLAN 10, VLAN 20에 연결되어있는 PC들과는 통신이 되고, VLAN이 달라서 R1에서 R3, R4로는 Ping이 빠지는, 통신이 되지않는 현상이 발생합니다.


왜냐하면 VLAN(Virtual LAN) (2) - Inter-VLAN Routing 게시글에도 나와있듯이 VLAN을 Routing해줄 Router가 하나 더 필요하기 때문입니다.


그래서 이왕 공부한걸 한번 더 써보자! 해서 Inter-VLAN 추가 실습을 해보려고 합니다.

  • Inter-VLAN 추가 실습

1. 새로운 Router, R5를 새로 추가하고, SW1 e0/0과 R5 f0/0와 연결해줍니다.


2. R5는 Inter-VLAN 전용 Router이며, f0/0.10과 f0/0.20 서브인터페이스를 추가해주고, 각각 1.1.10.0, 1.1.20.0 대역의 마지막 IP인 254를 설정해줍니다. 이 IP는 R1~R4 Router의 Gateway로 사용될 예정입니다.


3. 또한 R5의 SW1과 연결된 포트 구간Trunking Port로 활용하고 Encapsulation은 dot1Q로 설정해줍니다.

R5(config)#int fa 0/0 
R5(config-if)#no sh
R5(config-if)#int fa 0/0.10
R5(config-subif)#encapsulation dot1q 10
R5(config-subif)#ip address 1.1.10.254 255.255.255.0
R5(config-subif)#int fa 0/0.20
R5(config-subif)#encapsulation dot1Q 20
R5(config-subif)#ip address 1.1.20.254 255.255.255.0
R5(config-subif)#no sh
R5(config-subif)#
R5(config-subif)#exit
R5(config)#

Trunking Protocol과 서브인터페이스를 설정해 준 뒤 show ip interface brief, show running-config 명령어로 설정이 잘 되었는지 확인합니다.

R5#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  up                    up      
FastEthernet0/0.10         1.1.10.254      YES manual up                    up      
FastEthernet0/0.20         1.1.20.254      YES manual up                    up      
Serial1/0                  unassigned      YES unset  administratively down down    
Serial1/1                  unassigned      YES unset  administratively down down    
Serial1/2                  unassigned      YES unset  administratively down down    
Serial1/3                  unassigned      YES unset  administratively down down

R5#sh ru
// 생략
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 1.1.10.254 255.255.255.0
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 1.1.20.254 255.255.255.0
// 생략

4. 이제 SW1에 Trunking Protocol을 설정해줍니다.

SW1(config)#int e0/0
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#exit

설정해 준 뒤 마찬가지로 show interface status로 VLAN Mode가 잘 설정되었는지 확인합니다.

SW1#sh int stat

Port      Name               Status       Vlan       Duplex  Speed Type
Et0/0                        connected    trunk        auto   auto unknown
Et0/1                        connected    1            auto   auto unknown
Et0/2                        connected    1            auto   auto unknown
Et0/3                        connected    1            auto   auto unknown
Et1/0                        connected    1            auto   auto unknown
Et1/1                        connected    10           auto   auto unknown
Et1/2                        connected    20           auto   auto unknown
Et1/3                        connected    1            auto   auto unknown
Et2/0                        connected    1            auto   auto unknown
Et2/1                        connected    1            auto   auto unknown
Et2/2                        connected    1            auto   auto unknown
Et2/3                        connected    1            auto   auto unknown
Et3/0                        connected    1            auto   auto unknown
Et3/1                        connected    1            auto   auto unknown
Et3/2                        connected    1            auto   auto unknown
Et3/3                        connected    1            auto   auto unknown
Et4/0                        connected    1            auto   auto unknown
Et4/1                        connected    1            auto   auto unknown
Et4/2                        connected    1            auto   auto unknown
Et4/3                        connected    1            auto   auto unknown
Et5/0                        connected    trunk        auto   auto unknown
Et5/1                        connected    1            auto   auto unknown
Et5/2                        connected    1            auto   auto unknown
Et5/3                        connected    1            auto   auto unknown
5. 이후 각각의 Router에 정적 Routing을 구성해줍니다.
R1(config)#ip route 0.0.0.0 0.0.0.0 1.1.10.254
R2(config)#ip route 0.0.0.0 0.0.0.0 1.1.20.254
R3(config)#ip route 0.0.0.0 0.0.0.0 1.1.10.254
R4(config)#ip route 0.0.0.0 0.0.0.0 1.1.20.254
6. 이렇게 하면 모든 설정은 끝입니다. show interface trunk를 통해서 e0/0에 설정이 잘 되어있는지 확인합니다.
SW1#sh int tru 

Port        Mode             Encapsulation  Status        Native vlan
Et0/0       on               802.1q         trunking      1
Et5/0       on               802.1q         trunking      999

Port        Vlans allowed on trunk
Et0/0       1-4094
Et5/0       1-4094

Port        Vlans allowed and active in management domain
Et0/0       1,10,20,999
Et5/0       1,10,20,999

Port        Vlans in spanning tree forwarding state and not pruned
Et0/0       1,10,20,999
Et5/0       1,10,20,999
7. 이제 R1에서 R2로 핑을 때려봅시다.
R1#ping 1.1.20.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.20.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/54/92 ms
정상적으로 잘 가는 것을 확인할 수 있습니다!



이렇게 실습을 해보고나니 VLAN에 대해서 정확하게 개념을 이해할 수 있게 되었습니다.

VLAN, Inter-VLAN, Native VLAN. 이 3가지에 대해서 헷갈리지 않고 정확하게 알 수 있고, 설정할 수 있다면 기초적인 VLAN은 완벽하게 터득했다고 할 수 있을 것 같습니다.


알면 알 수록, 토플로지가 커지면 커질수록 재밌는게 네트워크인 것 같네요 :)


반응형

댓글을 달아 주세요