본문으로 바로가기
반응형
OSPF (Open Shortest Path First)

OSPF(Open Shortest Path Frst) 라우팅 프로토콜은 다른 라우터들에게 전체 네트워크 구성을 파악하기 위하여 필요한 정보들을 광고하는 링크 상태 라우팅 프로토콜(Link-state Routing Protocol)이다. EIGRP, RIP과 같은 디스턴스 백터 라우팅 프로토콜이 아니므로 스플릿 호라이즌 또는 자동 축약이 적용되지 않는다.

현재 IPv4에서 사용하고 있는 버전은 RFC 2328에 규정되어있는 OSPFv2 버전이며, 프로토콜 번호 89번을 사용하여 라우팅 정보를 전송한다. EIGRP와 다르게 OSPF는 표준 프로토콜로써 대부분의 제조사에서 지원하며, 가장 많이 사용되는 IGP(Interior Gateway Protocol)이다. OSPF는 Area 단위로 라우팅을 동작시킨다. 따라서 설정을 통해 각각의 에어리어에서만 네트워크 변화를 조정할 수 있어 대규모의 네트워크에서도 안정된 운영이 가능하다.


장비 기본 설정 & 기본 설정 파일
Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#enable secret cisco
R1(config)#no ip domain-lookup

R1(config)#line console 0
R1(config-li)#logging sync
R1(config-li)#exec-time 0
R1(config-li)#exit

ISP(config)#line vty 0 4
ISP(config-li)#password cisco
ISP(config-li)#exit


기본적인 OSPF 설정

OSPF가 동작하는 라우터의 각 인터페이스는 하나의 에어리어(Area)에 소속된다. 아래 사진과 같이 각각의 인터페이스에 OSPF Area를 설정해준다.

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1 
R1(config-router)#network 1.1.10.1 0.0.0.0 area 0
R1(config-router)#network 1.1.123.1 0.0.0.0 area 0

ⅰ. router ospf 1 : router ospf 명렁어를 사용하여 OSPF 설정 모드로 들어간다. 이 때 뒤에 붙는 숫자를 프로세스 ID(Process ID)라고 하며, 1~65,535 사이의 값을 임의로 부여한다. 프로세스 ID는 동일한 라우터에서 복수개의 OSPF를 동작시킬 때 서로 구분하기 위한 목적으로 사용하며, 쉽게 구분할 수 있도록 라우터별로 다른 값을 부여해도 상관없다.

ⅱ. router-id 1.1.1.1 : 라우터의 ID를 지정해준다. OSPF와 같은 링크 상태 라우팅 프로토콜은 라우팅 정보 전송 시 여러 값들을 전송하는데 이 때 정보를 전송하는 라우터가 어떤 라우터인지도 알려준다. 이 때 사용하는 값이 라우터 ID가 된다. 라우터 ID는 주로 루프백(Loopback) 주소로 라우터 ID 값을 지정하는 것이 제일 안전하며, OSPF 네트워크에 포함되지 않아도 된다. 또한 쉽게 ID를 확인할 수 있게끔 설정되어 있지 않은 IP 주소를 라우터 ID로 사용해도 된다. 만약 라우터 ID를 설정하지 않으면 동작 중인 인터페이스의 IP 주소 중에서 가장 높은 IP 주소가 자동으로 설정되며, 루프백이 설정되어 있다면 마찬가지로 가장 높은 IP 주소가 설정된다.

ⅲ. network 1.1.10.1 0.0.0.0 area 0 : OSPF에 포함시킬 인터페이스의 IP 주소와 와일드카드 서브넷 마스크, 에어리어를 지정한다. 에어리어가 하나일 때는 번호를 임의로 사용해도 되나 두 개 이상일 때는 그 중 하나를 반드시 에어리어 번호를 0, 0.0.0.0으로 설정해야한다. 이를 백본 에어리어(Backbone Area)라고 하며 다른 에어리어들은 항상 백본 에어리어와 물리적으로 직접 연결되어야 한다.


여기서 R2와 R3Area 0과 Area 1에 소속되어 있다. 이렇게 2개 이상의 에어리어에 걸쳐 있는 라우터ABR(Area Border Router)라고 한다.


R1 라우터에 sh ip route 명렁어를 입력하여 라우팅 테이블에 OSPF Inter Area 라우팅 경로(O IA)가 있는 것을 확인할 수 있다. 이는 다른 에어리어에 소속된 네트워크라는 뜻이다.

R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C        1.1.10.0/24 is directly connected, Ethernet0/1
L        1.1.10.1/32 is directly connected, Ethernet0/1
O IA     1.1.24.0/24 [110/20] via 1.1.123.2, 02:23:22, Ethernet0/0
O IA     1.1.34.0/24 [110/74] via 1.1.123.3, 02:22:40, Ethernet0/0
O IA     1.1.40.0/24 [110/30] via 1.1.123.2, 02:22:02, Ethernet0/0
C        1.1.123.0/24 is directly connected, Ethernet0/0
L        1.1.123.1/32 is directly connected, Ethernet0/0

R2와 R3의 라우팅 테이블을 확인해보면 동일한 에어리어로 소속된 네트워크인 OSPF 라우팅 경로(O)가 있는 것을 확인할 수 있다.

R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O        1.1.10.0/24 [110/20] via 1.1.123.1, 02:25:09, Ethernet0/0
C        1.1.24.0/24 is directly connected, Ethernet0/1
L        1.1.24.2/32 is directly connected, Ethernet0/1
O        1.1.34.0/24 [110/74] via 1.1.24.4, 02:23:39, Ethernet0/1
O        1.1.40.0/24 [110/20] via 1.1.24.4, 02:23:39, Ethernet0/1
C        1.1.123.0/24 is directly connected, Ethernet0/0
L        1.1.123.2/32 is directly connected, Ethernet0/0


OSPF 네이버 (Neighbor)

OSPF도 EIGRP와 비슷한 패킷인 헬로(Hello) 패킷을 이용하여 인접한 라우터와 네이버를 구성한다. OSPF의 헬로 패킷은 네트워크의 종류에 따라 10초 또는 30초마다 전송된다. 연속해서 4개의 헬로 패킷을 수신하지 못하면 네이버 관계를 해제하며, 이 타이머를 데드 주기(Dead Interval)라고 한다.


OSPF는 인접 라우터에서 헬로 패킷을 수신하고, 헬로 패킷에 포함된 네이버 리스트에 자신의 라우터 ID가 포함되어 있으면 그 라우터를 네이버(Neighbor)로 간주한다. 이 때 헬로 패킷에 나와있는 에어리어 ID, 암호(설정 시), 서브넷 마스크 길이, 헬로/데드 주기, 스텁(Stub) 에어리어 표시가 모두 동일해야한다. 네트워크의 종류마다 다르지만 가장 많이 쓰이는 이더넷포인트 투 포인트 네트워크에서의 OSPF 헬로 패킷 목적지 주소는 224.0.0.5인 멀티캐스트 주소를 사용한다.


show ip eigrp neighbors 명령어를 통하여 네이버 상태를 확인할 수 있다.

R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:33    1.1.123.1       Ethernet0/0
1.1.3.3           1   FULL/DROTHER    00:00:35    1.1.123.3       Ethernet0/0
1.1.4.4           1   FULL/BDR        00:00:35    1.1.24.4        Ethernet0/1

State : OSPF 네이버의 상태를 표시하며, 상태가 FULL이면 네이버와 라우팅 정보 교환이 끝났다는 뜻이다. OSPF는 라우팅 정보를 하나의 대표 라우터에게만 보내고 이 라우터가 나머지 라우터에게 중계하는 방식을 이용한다. 일일이 라우팅 정보를 교환하면 트래픽이 많이 발생할 수 있기 때문이다.

이와 같이 라우팅 정보 중계 역할을 담당하는 라우터를 DR(Designated Router)이라고 하며, DR에 장애가 발생했을 때 대신 DR 역할을 하는 라우터를 BDR(Backup DR)이라고 한다. DR도 BDR도 아닌 라우터를 DROTHER이라고 한다. DR, BDR은 포인트 투 포인트 네트워크에서는 사용되지 않는다.


DR, BDR의 우선순위는 1. 인터페이스의 OSPF 우선순위(Proirity), 2. 라우터 IP가 높은 순서대로 선출된다.

R2의 네이버 상태를 그림으로 나타냈을 때는 위와 같다. 우선순위는 건드리지 않았으므로 1로 동일하며, 라우터 IP가 높은 순서대로 선출 되는 것을 확인해야한다. 그렇다면 R4(1.1.4.4)가 DR, R3(1.1.3.3)가 BDR이 되어야하나 위 토플로지 설정시 R1 -> R2 -> R3 -> R4 순서대로 설정하였고, 그 때 정해진 R1과 R2 라우터의 BR, BDR문제가 생기지 않았으므로 라우터가 추가되더라도 DR과 BDR은 변경되지 않는다.


고로 R2가 DR, R1이 BDR이 되고, R3가 DROTHER이 되며, R4가 BDR이 되는 것을 확인할 수 있다. R4가 BDR이 되는 이유는 R1부터 R3까지 설정시에는 이더넷 네트워크이기 때문에 각각 DR, BDR, DROTHER이 설정이 되나 R4는 R2와는 이더넷 네트워크, R3와는 포인트 투 포인트 네트워크이기 때문에 R3와는 DR, BDR을 선출하지 않는다. 고로 R4의 이더넷 네트워크R2와 DR, BDR을 선출하면서 R2의 네이버에 R4의 e0/1 인터페이스인 1.1.24.4가 BDR로 선출된다.


Dead Time : 남아있는 데드 주기(Dead Interval)를 표시한다. 이 시간내에 헬로 패킷을 수신하지 못 할 경우 해당 네이버를 삭제한다.


OSPF는 라우팅 정보를 교환하는 네이버, 즉 DR과 BDR을 어드제이션트(Adjacent) 네이버라고 하며, 이들 간에만 라우팅 정보를 교환한다. DROTHER 라우터끼리는 어드제이션트 네이버가 되지 못한다.


OSPF 네이버 (Neighbor) - State(상태)의 변화

OSPF가 설정된 인터페이스에서 네이버의 상태는 일반적으로 네이버가 없는 다운(DOWN) 상태에서 시작하여 네이버와 라우팅 교환을 끝낸 풀(FULL) 상태로 변한다.


1. 다운(DOWN) 상태 : 네이버에게서 헬로 패킷을 받지 못한 상태이다.

2. 이닛(INIT) 상태 : 네이버에게서 헬로 패킷을 받았으나 상대 라우터는 아직 나의 헬로 패킷을 받지 못한 상태를 말한다. 이 때 상대방이 보낸 헬로 패킷의 네이버 리스트(Neighbor List)에 나의 라우터 ID가 없다.

3. 투웨이(2WAY) 상태 : 네이버와 쌍방향 통신이 이루어진 상태이다. 즉, 상대방이 보낸 헬로 패킷의 네이버 리스트에 나의 라우터 ID가 있다. 이 때 DR과 BDR을 선출하게 되며, 선출 과정의 공정함을 위해 웨이트 타임(Wait Time)이라는 시간 동안 기다리게 된다. 웨이트 타임은 데드 주기(Dead Interval)와 같으며 어떠한 장애로 인하여 끊겼다가 다시 네이버가 맺어지는 경우에는 웨이트 타임을 기다리지 않고 바로 DR, BDR을 선출하게 된다.

4. 엑스스타트(Exstart) 상태 : 라우팅 정보를 교환하는 어드제이션트(Adjacent) 네이버가 되는 첫 단계이다. 마스터(Master) 라우터와 슬레이브(Slave) 라우터를 선출한다.

5. 익스체인지(Exchange) 상태 : OSPF의 라우팅 정보를 LSA(Link State Advertisement)라고 하는데, 이 LSA를 저장하는 장소를 링크 상태 데이터베이스라고 한다. 이 데이터베이스에는 OSPF 라우터 자신이 알고 있는 모든 상세 네트워크 정보가 저장되어 있으며, 익스체인지 상태에서는 LSA의 헤더만을 DDP(Database Description Packet) 또는 DBD(DataBase Description)라고 부르는 패킷에 담아 상대방에게 전송한다.

6. 로딩(Loading) 상태 : 상대로부터의 DDP 패킷 수신이 끝난 후, 자신에게 없는 정보가 있으면 링크 상태 요청 패킷을 보내어 특정 LSA의 상세 정보를 보내줄 것을 요청하여 해당 정보를 수신하는 상태이다.

7. 풀(FULL) 상태 : 어드제이션트(Adjacent) 라우터들 간의 라우팅 정보교환이 끝난 상태이다. 이제 링크 상태 데이터베이스의 내용이 모두 일치하게 된다.


OSPF는 네이버 라우터와 LSA 교환을 끝낸 후 5초를 기다린 뒤 알고리즘을 계산하고 그 결과를 라우팅 테이블에 기록한다. 이 때 사용하는 라우팅 알고리즘을 SPF(Shortest Path First) 또는 다익스트라(Dijkstra) 알고리즘이라고 한다.


OSPF 메트릭 (Metric)

OSPF의 메트릭은 코스트(Cost)라고 불리우며 출발지부터 목적지까지의 각 인터페이스에서 기준 대역폭(reference bandwidth)실제 대역폭으로 나눈 값의 합계이다.[각주:3] R1의 1.1.10.1부터 R4의 1.1.40.4의 네트워크에 대한 OSPF 코스트는 목적지까지 가는 경로상에 존재하는 모든 인터페이스의 OSPF 코스트 값을 합친 것이다.

R1#sh int e0/0
Ethernet0/0 is up, line protocol is up 
  Hardware is AmdP2, address is aabb.cc00.1000 (bia aabb.cc00.1000)
  Internet address is 1.1.123.1/24
  MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
....

∑(10^8 / [n개의 라우터 대역폭 kbps] x 1000))

R1의 e0/0, R2의 e0/1의 대역폭 값은 각각 10,000kbps, 즉 1,000을 곱하면 10,000,000bps이다. 10^8승에서 10,000,000을 나누면 10이 나오므로 코스트는 각각 10, 10이다. 이 값을 총 더하면 20이 되므로 R1부터 R4까지의 OSPF 코스트값20이 된다.

R1#sh ip route
...
O IA     1.1.24.0/24 [110/20] via 1.1.123.2, 01:47:24, Ethernet0/0
O IA     1.1.34.0/24 [110/74] via 1.1.123.3, 01:47:24, Ethernet0/0
O IA     1.1.40.0/24 [110/30] via 1.1.123.2, 01:47:24, Ethernet0/0
R1#


OSPF 타이머 조정

OSPF는 이더넷과 포인트 투 포인트 인터페이스에서 10초마다 헬로 패킷을 전송한다. 빠른 장애 복구를 위해서 이 타이머를 줄여야 하는 경우에 간단한 명령어를 가지고 타이머를 조절할 수 있다. ip ospf hello-interval 명령어로 헬로 타이머를 조정할 수 있다.

R1(config)#int e0/0
R1(config-if)#ip ospf hello-interval 5
데드 주기인 약 40초가 지나게 되면 시스템 메세지와 함께 OSPF 네이버가 끊기는 것을 확인할 수 있다.
*Mar  2 06:33:58.240: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar  2 06:34:20.515: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.2.2 on Ethernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired
R1#
*Mar  2 06:34:43.528: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.3.3 on Ethernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired

이유는 위의 OSPF Neighbor(네이버)에서 설명했듯이 헬로 패킷에 나와있는 여러 내용 중에서도 통신할 라우터의 헬로, 데드 주기가 서로 동일하지 않아 네이버가 끊기기 때문이다. 고로 R2와 R3의 헬로 주기를 똑같이 조정하고나면 네이버가 살아나는 것(FULL State)을 확인할 수 있다.

R2(config)#int e0/0
R2(config-if)#ip ospf hello-interval 5
R3(config)#int e0/0
R3(config-if)#ip ospf hello-interval 5

*Mar  2 06:40:11.394: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.2.2 on Ethernet0/0 from LOADING to FULL, Loading Done
R1#
*Mar  2 06:40:26.008: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.3.3 on Ethernet0/0 from LOADING to FULL, Loading Done

이처럼 OSPF 헬로 주기를 변경하게 되면 데드 주기도 따라서 변경이 된다. 그러나 데드 주기를 변경한다고 해서 헬로 주기가 변경되지는 않는다. 데드 주기를 변경하려면 위의 명령어에서 hello를 dead로 변경해주면 된다(ip ospf dead-interval 5).


OSPF 라우팅 보안

OSPF도 패킷 인증 기능을 이용하여 보안을 강화시킬 수 있다. 단 네이버 간에만 인증을 구현하는 다른 라우터와는 달리 OSPF는 특정 에어리어 전체를 인증할 수 있다. 암호화 종류는 MD5와 평문 암호 교환이 있으며 보안성이 약한 평문 암호 교환은 사용하지 않는다.

Area 인증을 위해서는 OSPF 라우팅 프로세스로 접속한 뒤 인증키 교환방식을 정의하고 네이버와 연결되는 인터페이스에서 암호를 지정한다. 이 때 설정하는 암호와 키 번호가 네이버간 일치해야한다.

R1(config)#router ospf 1
R1(config-router)#area 0 authentication message-digest
R1(config-router)#exit
R1(config)#int e0/0
R1(config-if)#ip ospf message-digest-key 1 md5 NETSTUDY

R2(config)#router ospf 1
R2(config-router)#area 0 authentication message-digest
R2(config-router)#exit
R2(config)#int e0/0
R2(config-if)#ip ospf message-digest-key 1 md5 NETSTUDY

R3(config)#router ospf 1
R3(config-router)#area 0 authentication message-digest
R3(config-router)#exit
R3(config)#int e0/0
R3(config-if)#ip ospf message-digest-key 1 md5 NETSTUDY

네이버 인증을 위해서는 인증방식과 암호를 모두 인터페이스에 지정한다. 이 때도 마찬가지로 설정하는 암호와 키 번호가 네이버간 일치해야한다.

R2(config)#int e0/1
R2(config-if)#ip ospf authentication message-digest
R2(config-if)#ip ospf message-ditest-key 1 md5 NETSTUDY

R4(config)#int e0/1
R4(config-if)#ip ospf authentication message-digest
R4(config-if)#ip ospf message-ditest-key 1 md5 NETSTUDY 

만약 지정한 암호 또는 키 번호가 일치하지 않으면 아래와 같은 시스템 메세지와 함께 네이버가 해제된다.

*Mar  2 08:40:51.066: %OSPF-4-NOVALIDKEY: No valid authentication send key is available on interface Ethernet0/0
*Mar  2 08:41:04.896: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.2.2 on Ethernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired
*Mar  2 08:41:08.102: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.3.3 on Ethernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired

현재의 토플로지와 연결되어있는 종단장치가 접속되는 R1의 e0/1 인터페이스와 R4의 e0/0 인터페이스에 OSPF의 헬로 패킷 송수신을 차단하면 강력한 보안대책이 될 수 있다. 실제로 모든 IGP의 보안이 가장 필요한 위치는 종단장치가 접속되는 인터페이스이다.

OSPF 설정 모드로 접속 후 passive-interface [인터페이스] 명령어를 통해서 패시브 인터페이스를 설정해준다. 이 설정을 통해서 설정된 인터페이스를 통한 OSPF 헬로 패킷 의 송수신이 차단된다.

R1(config)#router ospf 1
R1(config-router)#passive-interface e0/1

R4(config)#router ospf 1
R4(config-router)#passive-interface e0/0


OSPF 디폴트 루트

OSPF를 이용하여 디폴트 루트를 설정하여 네트워크를 조정할 수 있다. 우선 Static Routing을 통해 디폴트 루트를 설정 후, OSPF 설정 모드로 접속한 다음 default-information originate 명렁어를 통하여 OSPF 프로세스 내의 다른 네이버들에게 디폴트 루트를 광고한다. 만약 정적 루트로 설정된 인터페이스가 다운되면 다른 네이버들에게 광고가 멈추지만, 뒤에 always 옵션을 추가하면 설정된 인터페이스가 다운되어도 항상 광고하게 된다.

R2(config)#ip route 0.0.0.0 0.0.0.0 1.1.123.1
R2(config)#router ospf 1
R2(config-router)#default-information originate

설정 후 R2의 라우팅 테이블을 확인해보면 S*(Static-Candidate default)로 디폴트 루트가 설정된 것을 확인할 수 있다.

R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 1.1.123.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 1.1.123.1
      1.0.0.0/8 is variably subnetted, 7 subnets, 2 masks

R4의 라우팅 테이블을 확인해보면 O*E2(OSPF-Candidate default OSPF external type 2)OSPF를 통하여 R2에게 광고를 받은 것을 확인할 수 있다.

R4#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 1.1.24.2 to network 0.0.0.0

O*E2  0.0.0.0/0 [110/10] via 1.1.24.2, 00:00:13, Ethernet0/1
      1.0.0.0/8 is variably subnetted, 8 subnets, 2 masks


  1. ROUTER, SWITCH는 각각 L3 IOU, L2 IOU 이미지를 사용하였다. [본문으로]
  2. 복사하여 터미널 프로그램에 붙여넣기 하면 편하게 사용할 수 있다. [본문으로]
  3. 시스코 IOS의 OSPF 기준 대역폭은 10의 8승(100,000,000)이다. [본문으로]
반응형

댓글을 달아 주세요

  1. rndrma 2021.11.10 16:32

    R2-R4는 이더넷이고 R3-R4는 포인트 투 포인트라고 하셨는데 둘 다 같은 상황아닌가요?
    왜 다른거에요?