반응형
TEST Network
ROUTER 시작 시 'Set-up Mode'가 나오는 경우
'Set-up Mode'는 실무에서 거의 사용하지 않는다.
1. 공장 출하 시
2. 관리자 모드에서 setup 명령어 사용 시
3. 설정 레지스터(Config Register)의 끝에서 두 번째 값이 0x2142처럼 4일 때
4. 설정 파일을 삭제(erase startup-config)한 후 재부팅할 때
빠져 나오는 방법 : Would you like to enter the initial configuration dialog? [yes/no] 에서 no 입력 or Ctrl+C
기본적인 Cisco ROUTER 모드 종류
Router>enable // 이용자 모드 (User Mode) >
Router#configure terminal // 관리자 모드 (Privilege Mode) #
Router(config)#interface ethernet 0/0 // 전체 설정 모드 (전역 모드) (Global Configuration Mode) (config)#
Router(config-if)#exit // 인터페이스 설정 모드 (config-if)#
Router(config)#line vty 0 4 // ↑전 단계 (exit)
Router(config-line)#exit // 라인 설정모드 (config-line)#
Router(config)#router ospf 1 // ↑전 단계 (exit)
Router(config-router)#end // 라우터 설정 모드 (config-router)#
Router# // ↑↑관리자 모드 단계 (end) (Ctrl + Z)
Cisco ROUTER 기본 설정 1
Router> // 이용자 모드 >
Router>enable
Router#configure terminal // 관리자 모드 #
Enter configuration commands, one per line. End with CNTL/Z. // 관리자 모드 진입시 나타나는 문구
Router(config)#hostname R1 // 라우터 이름 설정 (인증용 ID로도 사용된다.)
R1(config)#enable secret cisco // 라우터 관리자 모드 암호 지정 (MD5)
R1(config)#no ip domain-lookup // 문자열 입력으로 인한 DNS SERVER 찾는 시간 방지
Translating "xxxx"...domain server (xxx.xxx.xxx.xxx)
R1(config)#banner motd * // 배너 추가 (임의 문자 사용 가능)
Enter TEXT message. End with the character '*'.
DON'T ACCESS THIS ROUTER IF YOU DON'T HAVE AUTHORIZATION!!
*
R1(config)#line console 0 // 콘솔 라인 설정모드
R1(config-line)#logging synchronous // 시스템 메세지 표시 때 줄바꿈 위한 명령어
R1(config-line)#exec-timeout 0 // 명령어 입력 없을 때 콘솔 밖으로 빠져나오는 것 방지
R1(config-line)#exit // ↑전 단계
R1(config)#line vty 0 4 // 텔넷 라인 설정모드
R1(config-line)#password cisco // 텔넷 암호 지정
R1(config-line)#exit // ↑전 단계
R1(config)#exit // ↑전 단계
R1#copy running-config startup-config // DRAM(running-config)값을 NVRAM(startup-config)값으로 저장
Destination filename [startup-config]? // Enter
Building configuration... // 저장 중
[OK] // 저장 완료
Cisco ROUTER 현재 설정 확인
Router>enable
Router#show running-config // DRAM(running-config) 값 확인
Building configuration...
Current configuration : 1572 bytes
!
! Last configuration change at 07:36:09 EET Sat Feb 1 2020
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
...
Cisco ROUTER 초기화 방법
Router#erase startup-config // erase 명령어를 이용하여 NVRAM(startup-config) 값 제거
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
Router#reload // 재부팅
Cisco ROUTER 시간 확인
R1#show clock
*11:08:09.476 EET Thu Feb 6 2020 // 시:분:초.밀리세컨드 표준시 요일 월 일 년
R1#clock set 18:11:00 6 February 2020 // clock set 시:분:초 일 월 년
R1#
*Feb 6 16:11:00.000: %SYS-6-CLOCKUPDATE: System clock has been updated from 11:14:31 EET Thu Feb 6 2020 to 18:11:00 EET Thu Feb 6 2020, configured from console by console.
Cisco ROUTER 라인 상황 확인하기
Router#show line
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
* 0 CTY - - - - - 0 0 0/0 -
1 AUX 9600/9600 - - - - - 0 0 0/0 - // 현재 접속되어있는 LINE
2 VTY - - - - - 0 0 0/0 -
3 VTY - - - - - 0 0 0/0 -
4 VTY - - - - - 0 0 0/0 -
5 VTY - - - - - 0 0 0/0 -
6 VTY - - - - - 0 0 0/0 -
Cisco ROUTER Interface IP 기본 설정 & 주소 부여
R1#configure terminal // conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface serial 1/0 // int s1/0
R1(config-if)#description FOR R2 PORT // desc
R1(config-if)#ip address 172.17.1.1 255.255.0.0 // ip add
R1(config-if)#no shutdown // no sh
R1(config-if)#exit
R1(config)#interface ethernet 0/0 // int e0/0
R1(config-if)#description FOR ISP1 PORT // desc
R1(config-if)#ip address 192.168.11.10 255.255.255.0 // ip add
R1(config-if)#no shutdown // no sh
R1(config-if)#exit
R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface serial 1/0 // int s1/0
R2(config-if)#description FOR R1 PORT // desc
R2(config-if)#ip address 172.17.1.2 255.255.0.0 // ip add
R2(config-if)#no shutdown // no sh
R2(config-if)#exit
R2(config)#interface ethernet 0/0 // int e0/0
R2(config-if)#description FOR ISP2 PORT // desc
R2(config-if)#ip address 192.168.11.11 255.255.255.0 // ip add
R2(config-if)#no shutdown // no sh
R2(config-if)#exit
Cisco ROUTER Interface 동작 상태, 입력된 IP 주소 확인
Router#show ip interface brief // sh ip int br
Interface IP-Address OK? Method Status Protocol
...
R1#show ip interface brief // sh ip int br
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 192.168.11.10 YES manual up up
Ethernet0/1 unassigned YES NVRAM administratively down down
Ethernet0/2 unassigned YES NVRAM administratively down down
Ethernet0/3 unassigned YES NVRAM administratively down down
Serial1/0 172.17.1.1 YES manual up up
Serial1/1 unassigned YES NVRAM administratively down down
Serial1/2 unassigned YES NVRAM administratively down down
Serial1/3 unassigned YES NVRAM administratively down down
R2#show ip interface brief // sh ip int br
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 192.168.11.11 YES manual up up
Ethernet0/1 unassigned YES NVRAM administratively down down
Ethernet0/2 unassigned YES NVRAM administratively down down
Ethernet0/3 unassigned YES NVRAM administratively down down
Serial1/0 172.17.1.2 YES manual up up
Serial1/1 unassigned YES NVRAM administratively down down
Serial1/2 unassigned YES NVRAM administratively down down
Serial1/3 unassigned YES NVRAM administratively down down
Cisco ROUTER 각 Interface별 정보 확인
Router#show interface ethernet 0/0 // sh int e0/0
Ethernet0/0 is up, line protocol is up
Hardware is AmdP2, address is aabb.cc00.1000 (bia aabb.cc00.1000)
...
R1#show interface ethernet 0/0 // sh int e0/0
Ethernet0/0 is up, line protocol is up // 라인 상태
Hardware is AmdP2, address is aabb.cc00.1000 (bia aabb.cc00.1000) // MAC 주소
Description: FOR ISP1 PORT // Description
Internet address is 192.168.11.10/24 // IP 주소, 서브넷 마스크
MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set // Encapsulation, Loopback
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:02, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 2000 bits/sec, 2 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
496 packets input, 123673 bytes, 0 no buffer
Received 183 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
34 packets output, 3905 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
19 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Cisco ROUTER Routing Table 확인
Router#show ip route // sh ip rou
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
...
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
(생략)
Gateway of last resort is 192.168.11.2 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 192.168.11.2
172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.17.0.0/16 is directly connected, Serial1/0
L 172.17.1.1/32 is directly connected, Serial1/0
192.168.11.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.11.0/24 is directly connected, Ethernet0/0
L 192.168.11.10/32 is directly connected, Ethernet0/0
R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
(생략)
Gateway of last resort is 192.168.11.2 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 192.168.11.2
172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.17.0.0/16 is directly connected, Serial1/0
L 172.17.1.2/32 is directly connected, Serial1/0
192.168.11.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.11.0/24 is directly connected, Ethernet0/0
L 192.168.11.11/32 is directly connected, Ethernet0/0
- banner motd 부분의 *은 입력 시작과 끝을 나타내며, 다른 임의의 문자로 사용할 수 있다. 또한 default-value exec-character-bits 8 명령어를 사용 하면 한글로 배너를 달 수 있다. [본문으로]
반응형
'네트워크 > Cisco' 카테고리의 다른 글
Cisco SWITCH - 스위치 기본 설정, 확인 (302) | 2018.10.24 |
---|---|
Cisco ROUTER & SWITCH - telnet, SSH (0) | 2018.10.20 |
Cisco ROUTER & SWITCH- Static Routing, Debug, CDP(LLDP), Ping, Traceroute (0) | 2018.10.20 |